Installation

Requirements

OWSLib requires a Python interpreter, as well as ElementTree or lxml for XML parsing.

Install

PyPI:

easy_install OWSLib
# pip works too
pip install OWSLib

Git:

git clone git://github.com/geopython/OWSLib.git

Anaconda:

Note

The OWSLib conda packages are provided by the community, not OSGEO, and therefore there may be multiple packages available. To search all conda channels: http://anaconda.org/search?q=type%3Aconda+owslib However usually conda-forge will be the most up-to-date.

conda install -c conda-forge owslib

openSUSE:

zypper ar http://download.opensuse.org/repositories/Application:/Geo/openSUSE_12.1/ GEO
zypper refresh
zypper install owslib

CentOS:

wget -O /etc/yum.repos.d/CentOS-CBS.repo http://download.opensuse.org/repositories/Application:/Geo/CentOS_6/Application:Geo.repo
yum install owslib

RedHat Enterprise Linux

wget -O /etc/yum.repos.d/RHEL-CBS.repo http://download.opensuse.org/repositories/Application:/Geo/RHEL_6/Application:Geo.repo
yum install owslib

Fedora:

Note

As of Fedora 20, OWSLib is part of the Fedora core package collection

yum install OWSLib